慕容的工作随笔

慕容的工作随笔

记录学习和工作

【转载】homestead安装php扩展

转自:https://segmentfault.com/a/1190000021769857

https://blog.csdn.net/xiaoyangxiaodong/article/details/114821789

https://iwantjingjing.com/2018/12/17/homestead-%E5%AE%89%E8%A3%85PHP-mongo-%E6%89%A9%E5%B1%95/

https://learnku.com/articles/33412

homestead 本身自带了很多扩展,一般不需要再次安装,但是遇到一些特殊的还是需要安装,比如说swoole,mongodb。今天已安装mongodb扩展为例子,毕竟算是踩过的坑。

本身 homestead的官网上提出一种很简单的方式,比如说:只需要在 Homestead.yaml 中加入 mongodb: true 即可,如下:
在 Homestead.yaml

    ---
    ip: "192.168.10.10"
    memory: 2048
    cpus: 1
    provider: virtualbox
    
    # 使用 MongoDB
    mongodb: true

如果你这么做了,你会发现,报错,根本安装不成功,其他环境我不知道是否会成功,但是在windows下面和manjaro(linux)都安装失败。

网上还有一些方法,我都试过,发现问题,就是因为homestead默认安装了好几个php版本,而默认的是最新的版本,可以用

php -v

查看默认版本。一般是最新,比如7.4.1.
但是假如我要安装7.3的版本的扩展怎么办?
如果采用网上的一些方法,就容易出现问题,比如很多人建议:

sudo pecl install mongodb

这种安装上了也是7.4版本的。
我们现在以7.3版本为例。

 

  • 下载: wget http://pecl.php.net/get/mongodb-1.7.2.tgz
  • 解压:tar zxf mongodb-1.7.2.tgz
  • 进入目录:cd mongodb-1.7.2
  • 运行 phpize7.3 生成相应的 configure 文件
  • 指定扩展基于php7.3 版本:sudo ./configure --with-php-config=/usr/bin/php-config7.3
  • 编译安装:sudo make && sudo make install

评论 (0)

还没有评论,来做第一个吧。

发表评论

提交后需管理员审核通过后显示