慕容的工作随笔

慕容的工作随笔

记录学习和工作

CentOS7 docker httpd运行错误问题

转自http://elkpi.com/topics/centos7-docker-httpd-error.html

File exists: AH01762: Failed to create shared memory segment on file /run/httpd/authdigest_shm.7
File exists: AH01760: failed to initialize shm - all nonce-count checking, one-time nonces, and MD5-sess algorithm disabled
AH00020: Configuration Failed, exiting
结果httpd就自己退掉了,如果手动进入docker内部手动启动,其实是可以成功运行的。后来一查,是因为docker启动后,并不会创建/run/httpd

因此在执行之前,加入以下一些处理:

删除原有的,再次创建,保证/run/httpd目录的存在后,再运行httpd,即可解决该问题。

评论 (0)

还没有评论,来做第一个吧。

发表评论

提交后需管理员审核通过后显示